This article is for users who have installed or upgraded Analyze "side-by-side" on the same box with the LAE (old version) software.
PROBLEM BACKGROUND:
Post upgrade, you may see an error like this when trying to run a node:
General Errors:
Unable to connect to the Data3Sixty Analyze Server.
Contact your system provider to ensure that the Data3Sixty Analyze Server is
running at the expected location on localhost:7731.
ROOT CAUSE:
The old Linux environment variables may be still pointing to LAE.
If you have LAE (our old software) installed, you'll need to ensure that your Linux environment has NO references to any LAE folders. This applies both to doing the initial install, and any time you wish to start Data360 Analyze - any environment references to the old software will cause Analyze to not start properly.
Note: using both systems on the same user account may cause you difficulty with system limits such as max number of open files, or max number of tasks.
RESOLUTION:
To resolve this, you'll need to clean out the LAE environment variables and restart Analyze. This ensures that there are no links to LAE.
Cleaning the variables can be done in one of three ways:
1) don't load LAE/ .profile.lavastorm for the current login session
2) manually remove all references to LAE from any environment variable
3) use the attached source clearEnv.sh script - RECOMMENDED
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