We recommend switching to the latest versions of Edge, Firefox, Chrome or Safari. Using Internet Explorer will result in a loss of website functionality.

Import CSV file - unrecognized characters on the end

Comments

3 comments

  • Avatar
    Donald Graham

    I want to attach the original file. When I copied and pasted the 3 rows it did something to the data so the node did read it in. Please see the techex_accounts.csv file please.

     

    Attached files

    techex_accounts.csv

     

    0
    Comment actions Permalink
  • Avatar
    Gerry Mullin

    There's an hidden parameter that can be added to the CSV/Delimited node in order to get your file work. It will be added into a future release but for now you can add it manually. Attached is a data flow reading both your files, for the second file I needed to add the UnescaptedQuote parameter. Here's the steps:

    1. Navigate to Define on the CSV/Delimited node.
    2. Create a parameter named UnescapedQuoteCharacter. Once its created go to Edit Details for the parameter (hamburger menu on the right of the name).
    3. Ensure the Run Time Property Name is ls.brain.node.csv.unescapedQuoteHandling.
    4. The Type should be set to Choice with the following choices: Error, Skip Value, Stop at Closing Quote and Stop at Delimiter.
    5. For this file, I set it to "Stop at Delimiter". You have 2 records that have more than 6 fields in them. You would need to tag on a second node to handle any fall out.

    Hope this helps!

     

    0
    Comment actions Permalink
  • Avatar
    Gerry Mullin

    Adding a new data flow with several options to read the file, as it looks like using "Stop at Delimiter" is causing 2 rows to get merged together making it easy to lose a row of data in this case.

     

    Attached files

    Unescaped Quote CSV.lna

     

    0
    Comment actions Permalink

Please sign in to leave a comment.