We recommend switching to the latest versions of Edge, Firefox, Chrome or Safari. Using Internet Explorer will result in a loss of website functionality.

Infogix Assure 9.2 - Error in server.log

Comments

1 comment

  • Avatar
    Brenda Stoetzer

    Hi Karen,

    That message will occur in a clustered environment that doesn’t have web servers between the load balancer and the JVMs. When one Wildfly JVM communicates to another Wildfly JVM, it’ll look for a web server on the other node. Without the web server, this error occurs instead since the other node wasn’t able to process the request. There isn’t any impact caused by this kind of setup, other than message will appear regularly in the logs.

    If this is for a fresh installation of the product prior to the Wildfly configuration being initialized, this setting below can be set in the appserver.properties. This setting will disable the modcluster feature and prevent the errors from occurring. If Wildfly instances are already created, changing this setting and deploying won't have any impact. It would need to be set very early in the installation, prior to creating the Wildfly instances.

    WILDFLY_USE_MOD_CLUSTER=false

    If this is for an existing installation, then the easiest method is to edit each Wildfly node’s standalone-full-ha.xml and remove the tags within the modcluster subsystem’s configuration and then restart the JVMs. In theory, you could remove and recreate the entire Wildfly instance to use the ‘fresh installation’ option, but that’s not as quick as editing the standalone-full-ha.xml.

    modcluster subsystem’s configuration original value:

           <subsystem xmlns="urn:jboss:domain:modcluster:2.0">
               <mod-cluster-config advertise-socket="modcluster" proxies="InfogixWebserver" advertise="false" connector="default">
                   <dynamic-load-provider>
                       <load-metric type="cpu"/>
                   </dynamic-load-provider>
               </mod-cluster-config>
           </subsystem>

    modcluster subsystem’s configuration modified value:

           <subsystem xmlns="urn:jboss:domain:modcluster:2.0">
           </subsystem>

                   

    0
    Comment actions Permalink

Please sign in to leave a comment.