We recommend switching to the latest versions of Edge, Firefox, Chrome or Safari. Using Internet Explorer will result in a loss of website functionality.
Our Support systems migrated on Saturday, May 21. We'll automatically forward you to the new location for this content.

MariaDB Connection

Comments

1 comment

  • Avatar
    Infogix Support
    Originally posted by: awilliams1024

    Hi Dimitry,

    I have not tried this myself and I do not have access to a LAE 5.1 instance, but what you describe appears to be correct - the mariadb-java-client-1.x.y.jar needs to be in the <LAE install Dir>\lib\java\ext folder.

    Note that you will have to use a 1.x version of the driver as it needs to be compatible with the version of Java used by LAE (1.7).

    You will need to configure the DbDriver property with the driver class name e.g. "org.mariadb.jdbc.Driver" and the DbUrl property e.g. "jdbc:mariadb://myserverhost:3306/db"

    This page has some useful information on compatibility and usage of the driver:

    https://mariadb.com/kb/en/library/ab...b-connector-j/
    0
    Comment actions Permalink

Please sign in to leave a comment.