We recommend switching to the latest versions of Edge, Firefox, Chrome or Safari. Using Internet Explorer will result in a loss of website functionality.
Our Support systems migrated on Saturday, May 21. We'll automatically forward you to the new location for this content.

LavaStorm License Validation

Comments

5 comments

  • Avatar
    Infogix Support
    Originally posted by: gmullin

    You can set a parameter in conf/site.prop and use forward slashes instead of backslashes:

    ls.brain.server.licensePath="C:/My Directory/Some Directory/license"
    0
    Comment actions Permalink
  • Avatar
    Infogix Support
    Originally posted by: jpstory

    Hi gmullin

    Thanks for looking at this, I have tried your method by using forward slashes, I still got the same error,

    Lavastorm is still searing the license file in "C:\WINDOWS\system32\Program Files (x86)LavastormLAETemplicense\Lae_6.1_License.lic"

    Any other possible solution? I even tried restar my PC, still not working.
    0
    Comment actions Permalink
  • Avatar
    Infogix Support
    Originally posted by: gmullin

    Open up a cmd window, navigate to where you installed Lavastorm and go into the bin directory, e.g. C:\Program Files\Lavastorm\LAE6.1.4\bin.

    Run (no quotes) 'laeEnv.bat' and then 'getProperties -d' to see all the properties LAE is using. In your case you could run 'getProperties -d | findstr lic' to limit the results. Look for the value ls.brain.server.licensepath. What does it say? If it isn't showing the new value you put in your site.prop then it's getting overridden somewhere.

    Does conf/site.prop only have that parameter defined once?
    0
    Comment actions Permalink
  • Avatar
    Infogix Support
    Originally posted by: jpstory

    Hi
    Unfortunately my acces to C drive is restricted.

    However, I manually opened up laeEnv.bat file and see"

    set LAE_HOME=C:/Program Files (x86)/Lavastorm/LAE6.1
    set PYTHONHOME=%LAE_HOME%/platform/windows-x86-32/python
    set PYTHONPATH=%LAE_HOME%/lib/windows-x86-32;%LAE_HOME%/lib/python
    set LD_LIBRARY_PATH=%LAE_HOME%/lib/windows-x86-32
    set JAVAHOME=%LAE_HOME%/jre
    set OSHOME=%LAE_HOME%/platform/windows-x86-32/os

    set LS_INSTALLDIR="C:/Program Files (x86)/Lavastorm/LAE6.1"
    set LS_SCRATCHDIR="C:/Program Files (x86)/Lavastorm/LAETemp"

    set PATH=%PYTHONHOME%/Lib/site-packages/pywin32_system32;%PYTHONHOME%/Lib/site-packages/win32/lib;%PYTHONHOME%/Lib/site-packages/win32;%PYTHONHOME%/Lib;%PYTHONHOME%;%PYTHONHOME%/DLLs;%LAE_HOME%/lib/windows-x86-32;%LAE_HOME%/bin;%LAE_HOME%/bin/windows-x86-32;%JAVAHOME%/bin;%OSHOME%/bin;%OSHOME%/lib;%PATH%
    set TERR_HOME=%LAE_HOME%/TERR
    set JAVA_HOME=%JAVAHOME%
    set PATH=%TERR_HOME%/bin/i386;%PATH%


    The license serach path was set only once, as the site.prop file has:

    ls.home="C:/Program Files (x86)/Lavastorm/LAE6.1"
    ls.arch="windows-x86-32"
    include "${ls.home}/conf/ls.prop"

    ls.brain.server.licensePath="C:/Program Files (x86)/Lavastorm/LAETemp/license"
    ls.brain.machineName="H840T7LVS7XQ7VT"
    ls.brain.server.host="127.0.0.1"
    ls.installDir="C:/Program Files (x86)/Lavastorm/LAE6.1"
    ls.brain.drone.executor.binary.extensionHandler.py ="${ls.home}/platform/windows-x86-32/python/python.exe"
    ls.brain.brxDeploymentDir="C:/Program Files (x86)/Lavastorm/LAETemp/deploy"
    ls.logDir="C:/Program Files (x86)/Lavastorm/LAETemp/log"
    ls.tempDir="C:/Program Files (x86)/Lavastorm/LAETemp/tmp"
    ls.desktop.install=true
    0
    Comment actions Permalink
  • Avatar
    Infogix Support
    Originally posted by: gmullin

    I'll send you a message through your support ticket.
    0
    Comment actions Permalink

Please sign in to leave a comment.