We recommend switching to the latest versions of Edge, Firefox, Chrome or Safari. Using Internet Explorer will result in a loss of website functionality.

Unescaped Quote Character

Comments

8 comments

  • Avatar
    Lailatul

    I'm sorry, I missed the file header. Please see attached.

    0
    Comment actions Permalink
  • Avatar
    Adrian Williams

    Can you try attaching the file again. You need to first choose the file and then click the "Attach File" button before clicking the "Submt" button.

    0
    Comment actions Permalink
  • Avatar
    Lailatul

    hello attach is the file

     

    Attached files

    header.xlsx

     

    0
    Comment actions Permalink
  • Avatar
    Adrian Williams

    The file you have attached is a .xlsx file, not a .csv file. The file does not contain any double quote characters so the error shown in your screenshot does not occur when I attempt to import the file (as a .xlsx file using the Excel File node, or when saved as a .csv file and imported using the CSV/Delimited Input node).  

    However, there are still issues with the data. There are duplicates of the 'Name' field and the 'Start Date (A)' field which will cause errors.

    If the actual data file you are trying to import is a .csv file and the file has a well known structure that will not change, you can configure the CSV/Delimited CSV Inpiut node to skip the header row and manually supply the header names:

     

    The 'HasHeaderLine' property is set to False to indicate the first line in the file should not be used a header record.

    The 'SkipHeaderRows' property is set to 1 to instruct the node to skip the first line before attempting to parse the data.

    The 'FieldNames' property is configured with the comma-separated list of field names to be applied to the data. Note that the field names should be modified to remove any duplicate names. In my test I appended the suffix "_0" to each of the duplicate names,

     

    When the file you attached was read by the Excel File node it also generated a duplicate names error. In this case this can be overcome by setting the 'DuplicateFieldNameAction' property to AutoName - which will append a unique suffix to each duplicate field name (which is "_0" for the first duplicate of a name).

     

     

    0
    Comment actions Permalink
  • Avatar
    Lailatul

    the original file is csv. I have followed the step you shown. I fill in the field name manually but still receive the same error

     

    Attached files

    header.csv.csv

     

    0
    Comment actions Permalink
  • Avatar
    Lailatul

    I believe it is due to the escape character * in the field names. But even if I fill the * in EscapedCharacter space it still error

    0
    Comment actions Permalink
  • Avatar
    Adrian Williams

    The file you have attached is a tab-separated file, not a comma-separated file, here as seen when opened in Notepad++

     

    When the CSV/Delimited Input node is configured is configured as shown below the example file you supplied can be read (obviously, there being no data records in the file):

    Other than the properties shown above, the only other property that was set was that for the filename (the 'Data' property).

     

    0
    Comment actions Permalink
  • Avatar
    Adrian Williams

    This is the value that I used in the 'FieldNames' property (including the changes to remove the duplicates):

    Account Name,Resource Name,Name*,Project Name,Name,Start Date (A),Day of End Date (A),End Date (A),Measure Names,A#,Account,Notes Use,Policy More info,Policy More info Text ,Remote_Delivery__C*,Start Date (A) (copy),Work_City_Psa__C,Work_Country_Psa__C,Work_Postalcode_Psa__C,Work_State_Psa__C,Work_Street_Psa__C,Name_0,SOW/PO Number,Start Date (A)_0 
    0
    Comment actions Permalink

Please sign in to leave a comment.